mirror of
https://codeberg.org/unspeaker/tengri.git
synced 2025-05-14 02:50:15 +02:00
14 lines
482 B
Nix
14 lines
482 B
Nix
#!/usr/bin/env nix-shell
|
|
{pkgs?import<nixpkgs>{}}:let
|
|
stdenv = pkgs.clang19Stdenv;
|
|
name = "tengri";
|
|
nativeBuildInputs = with pkgs; [ pkg-config libclang ];
|
|
buildInputs = with pkgs; [ libclang ];
|
|
LIBCLANG_PATH = "${pkgs.libclang.lib.outPath}/lib";
|
|
LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath (with pkgs; []);
|
|
in pkgs.mkShell.override {
|
|
inherit stdenv;
|
|
} {
|
|
inherit name nativeBuildInputs buildInputs LIBCLANG_PATH LD_LIBRARY_PATH;
|
|
}
|